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E\QLWEiNTEK cMT X Series Easyweb 2.0

Chapter 1 System Settings

1.1 Overview

Easyweb 2.0 is a web interface that allows users to configure parameters of cMT X Series HMI.
Additionally, with its Webview feature, users can monitor HMIs through a web browser. This user

manual explains the cMT X Series HMI features that can be configured using Easyweb 2.0.

1.2 Ways to Log In Easyweb 2.0

Connect an HMI via an Ethernet cable, and log in system settings in one of the following ways.

Via internet browser
Open internet browser (Windows Edge, Chrome, or Firefox), and enter HMI’s IP address (e.g.:
192.168.2.121). The web page below opens. If Webview interface is shown after entering the IP

address, please enter https://HMI_IP/admin to open Easyweb 2.0 system login page.
ElE =]

@ T ® 4

<« ¢ A F=£ | 192168.212Vadmin/loginfredirect=%2Fweb_ihmi%2Findex.php « ® 0OHd g @ :

Set on cMT Viewer devices

Launch cMT Viewer App, tap Search, select the HMI and tap icon to configure.
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Search
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cMT-4C66
192.168.2.121

Default HMI
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192.168.2.127
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Default HMI
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1.3 Easyweb 2.0 Login Identities

Three identity levels exist in Easyweb 2.0: [Admin], [Update], and [History]. [Admin] controls all the
settings while [Update] controls limited items. For safety, specify a password before configuration.
A password is needed for opening [History] settings, and the historical data can be backed up after
logging in with password.

The default password is 111111. After successful login, the password for each identity level can be

changed in [System Password] page.

@ T ® 4
= & A F==2 | 192168.2121/admin/loginfredirect=%2Fweb_ihmi%2Findex.php « &% O R3 o] @ H

I Admin

Addmin
-
Update

. History
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1.4 Easyweb 2.0 Interface
Dashboard

System status and HMI status are displayed in Dashboard after login.

@ cMT- Dashboard x |+

€& > C A F=2| 192168.2.121/admin/dashboard/info

9 Dashboard

System Status

® Now Date

2020/04/01 05:52:31

HMI Status

cMT-4C66

20200218

= | =] 3
* 9 OB EQR @ :

S admin v

@ Up Time

1:8:14

V2.0.11

Info

In this page the user can edit HMI Name / Date / Time.

@ oMT - System Info x  +

¢ > C A F=2 | 192168.2.121/admin/system/info

b Dashboard / System

HMIName:

\\G MT315;2.X

Date/Time:

2020-04-01 06.01.:51

Edit

=B 3%

* 90O BEQ @ :

S admin v
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Network » Ethernet
In this page the user can set the IP address of each Ethernet port.

@ cMT- Ethernet x |+

&«

C A F=2 | 192.168.2.121/admin/network/ethernet

Dashboard / Network / Ethernet

\ @ cMT3152X 19

b 20 \

LAN 1 (WAN) LAN 2 (LAN)
Mac Address: 00:0c:26:1b:4c:68
Gonfigure IP: Automatic [&
Address: 192 . 168 . 2 . 121
Netmask: 255 . 255 . 252 . O
Galeway: 192 . 168 . 1 . 254
DNS: 168 . 95 . 1 -1

=S
* 9 OB EQR @ :

s admin v

Project » Project Management

In this page the user can restart / update / back up the project file.

@ cMT-Project Management X | =+

& > C A =2 | 192.168.2.121/admin/project/management
& Dashboard / Project / Project Management
\ ’ cMT3
E:
Project Management
Restart Project: Restat C
= Project Update Project:
e Project Management Backup Project: Backup
USB/SD Update:

* a O BEQ @ :

- admin
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Project » Email

In this page the user can edit email contacts; e.g., the groups a contact is in, and email addresses.

=0 NCH S

@ cMT - Email x 4+

& > C A F=2|192168.2.121/admin/project/email # 4 O @ o= @ H

Dashboard / Project / Emai - admin v

\" cMT31 5?)(

SMTP Contacts Upload

*Host: stmp.gmail.com

* Username: test@gmail.com

@ Email
* Password:

* Gonfirm Password:
Authentication: ()
Encryption: None O TS SSL

Sender Information

“Name: Local HmI Use HMI Name

Project » Enhanced Security

In this page the user can set operable classes and password for each account.

o|=] &
@ cMT - Enhanced Security x  +
¢ > C A F=2 | 192168.2.121/admin/project/security 4 ® 0O M g =@ :
& Dashboard / Project Enhanced Security A admin
\\ ’ cMT3152X
W 1}
Accounts Import User Accounts
0 Pe a
Passwor
D Hide  Account - A B c D E E G H 1
1 admin 111111 ~ v v N e e N Ve v
# Enhanced Security 2 user1 111 v
3 user2 222 i ~
4 user3 333 v v v
5 userd 444 \/ v \/ s
6 user5 555 ~ ~ v v vy
7 usert 666 ~ v ~ ¥ g i

£
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Project » Recipe

In this page the user can update, back up, or clear recipe data on HMI.

@ cMT - Recipe x 4+

& > C A F=2 | 192.168.2.121/admin/project/recipe * % O M o]

Dashboard / Project Recipe - admi
)
Action
fem
Update Backup Glear

Recipe Database Backup Clea
o
Backup ;ag

=@ ¢

n v

Data » Data Log & Trend Display

This page displays data log and the corresponding trend. The data can be exported or backed up.

@ cMT- Data log & Trend x 4+
€ - C A F=2 | 192.168.2.121/admin/data/datalog % ® O H 2]
Dashboard / Data / Data log & Trend 2  admi
52X
20
Data Log Trend Display
Object:  logooo
T Refresh
# < Time = Channel 1 Channel 2 Channel 3
Einn Eog & stasspioy 235778  (© 2020/04/D1 13:27:39 -0 422618 0574748 1.19927
235777  (© 2020/04/D1 13:27-38 0173648 D 777817 118177
235776  (© 2020/D4/D113:27:37 0.130526 0959746 1.09625
235775 O 20200401 13:27:36  0.382683 -1.0587 0.97082
235774  ( 2020/04/D1 13:27:35 0 608761 -109915 0802957
235773  (© 2020/04/D113:27:34 0793353 -107886 06
235772  (® 2020/04/D11327-33 0939693 0980107 0330765

¥ Export to Spreadshest & Backup database

=1 NCIH
=@ ¢

n v

@ Option
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@ cMT- Data log & Trend x 4+
g

& > C A F=2|192168.2.121/admin/data/datalog # 4 O @ o= @ H

= Dashboard / Data / Data log & Trend = admin v
© cMT3152X "b

Data Log Trend Display

Object:  logooo

Auto Refresh 2 Refresh @ Option

45

@ Datalog & Trend Display 10

1:23PM 124 PM 125 PM 1:26 PM 1:27 PM 1:28 PM 1:29 PM 1:30 PM 131 PM
—-0.382683 —— 0914617 —-12

X. Division & Y. Division 7

Data » Event Log

This page displays event logs, and the data can be exported or backed up.

HEIES

@ MT-Eventlog x  +

¢ G A F=2 | 192168.2.121/admin/data/eventlog % ® 0[ Bl =@ :
b Dashboard / Data / Eventlog - admin v

Time column
2020-03-04 o 2020-04-01

Category range (0 - 255)

0 255 -
Keywords Select Language
Add terms Language1
# Calegory Eveni Message Event trigger time Retum ip normal time Occurence count
1 1 TankError!! (© 2020/04/01 13:31:25 ® 3 2
2 1 Machine Error It ® 2020/04/01 13:31:25 @ 2020/04/01 13:31:31 44
3 255 Start Memory Test  © 2020/04/01 13:31:17 ® 1
4 1 :IOW SpeedErmr ® 2020/04/01 13:31:12 ( 2020/04/01 13:31:20 17
5 1 Machine Error 1! © 2020/04/01 13:31:10 @ 2020/04/01 13:31:18 43
6 1 TankEror 1! © 2020/04/01 13:31:06 @ 2020/D4/01 13:31:15 30
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Data » Operation Log

In this page the user can back up operation logs.

= [=] s
@ cMT - OperationLog x  +
¢ > C A Fs=2 | 1921682121/admin/data/operationLog %« ® O @ B =@ :
Dashboard / Data / OperationLog - admin

\ = EMT3152X

= b 2.0

+ Backup database

@ OperationlLog

Features » Webview Setting
In this page the user can enable Webview and set password. Please see Chapter 2 in this user

manual for more details.

S[@] =
@ MT - Webview setting x 4+
€ - C A F=2 | 192168.2.121/admin/features/webview * ®% O H o= @ H
Dashboard / Features [ Webview setting - admin v~
\ © cMT8152X =
E b20
webview w

Enable: [ @)

set as homepage

Control User: password free

Change password

@ Features

@ Control users can control Webview

& Webview Setling

£
021-87700210 <y
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Features » EasyAccess 2.0

In this page the user can activate EasyAccess 2.0 and configure the proxy server.

= | =] 3E
@ cMT-EA20 x 4+
& > C A F== | 1921682.121/admin/features/eas20 * ®# O | B =@ :
Dashboard / Features EA2O0 L] admin v

\ © cMT3152X g
= b 20 \

EasyAccess 2.0 Proxy

Hardware key:  7BCPIYER-NVGA-7PM5-DJUG-QGIM-PAULBURC
Status: Not Activated

Click to Activate with Pariner Account

@ Features

Features » CODESYS

In this page the user can activate CODESYS® and manage settings for firmware updates.

HEIES

@ cMT-CODESYS x |+

¢ > C A F=2 | 1921682121 /admin/features/codesys 4 ® 0O® g =@ :
Dashboard / Features CODESYS ] admin

Status

Status: Not Activated

Click to Activate

@ Features

£
021-87700210 <y
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Account » System Password

There are four different levels of password protection: System Setting, Update Project, History, and
User, and in this page the user can change the passwords. The default passwords are 111111.
[System Setting]: This is the highest level. It has an access to change all system settings, download,
upload project, back up historical data, or change passwords for other levels.

[Upload Project]: This level can download, upload project, and back up historical data.

[History]: This level controls FTP access and it can back up historical data.

[User]: This level can operate cMT X projects via cMT Viewer. Other three levels above can all do
this.

o|=] E
@ cMT - Password x 4+
& > C A F=2|192168.2.121/admin/account/password # 4 O @ o= @ H
Dashboard / Account Gontro Password A admin
| Please select identity to edit password.
System Setting
Gurrent password:
New password:
8 Account
Caonfirm new password-
® Sysiem Password
Submit Reset
System Setting
Update Project
History
User
www.nicsanat.com
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Chapter 2 How to Use Webview

2.1 Overview

cMT X Series HMI can be monitored and controlled using an internet browser (Windows Edge,
Chrome, or Firefox). Up to 4 users can log in simultaneously.

2.2 Enabling Webview

Log in Easyweb 2.0, open Webview Setting page and toggle on [Enable]. In this page, whether a
password is required for logging in Webview can be set.

@ MT - Webview setting x 4+

€ - C A F=2 | 192168.2.121/admin/features/webview * ®% O H o= @ H

Dashboard / Features [ Webview setting - admin v~

webview w

Enable: [ @)
set as homepage

Control User: password free

Change password
Features

@ Control users can control Webview

Webview Setting

2.3 Log In Webview using an Internet Browser

Step1l. Open internet browser and enter HMI's Webview address (e.g.: 192.168.2.121
/app/dashboard). In Webview settings, if “Set as homepage” option is selected, then
simply enter the IP address (e.g.192.168.2.121). Webview interface opens after entering
the password.

021-87700210




=[] s
S ot x |+

& C A F=2 | 192168.2.121/app/login?auto=stop - % ® O M B @ :

Control Mode

Step 2. The HMI screen is displayed in the browser window. Certain HMI screen resolutions may
exceed the browser window size. When this happens, to change the view area, drag the
white frame that represents browser window in the lower-right corner and move within

the gray area that represents HMI screen.

[=[E] %
S cMT x +

3 C A F=2 | 192168.2121/app/dashboard - % @® 0O M B =@® :

|IC Viewer

VNC Viewer run on HMI allows remote monitoring devices with VNC Server installed for
flexible operation.

VNC Server on

Step 3. The toolbar that opens by clicking the three-line icon in the upper-left corner of the
window is shown below. From left to right, the toolbar is separated into three groups of

items.

021-87700210




In the first group, the HMI screen can be resized to fit in the browser window, or
displayed with HMI’s actual screen resolution.

In the second group, the position of the icon that opens the toolbar and the dragging
panel that moves the view area can be changed.

In the third group are the system settings icon and the logout icon.

0 Note

B When “Set as homepage” is selected in Webview, the Webview interface can be opened by
directly entering HMI IP address. When login password is forgotten, please enter

https://HMI IP/admin to return to the default system settings page. This prevents the

situation where Webview functions cannot be used once password is forgotten.

2.4 When Webview Doesn’t Open

When a login attempt fails and the page below shows, try the following ways to troubleshot.

1. Check whether Webview is enabled for the HMI.

2. Check whether the browser supports Webview, and please use recommended browsers such as
Windows Edge, Chrome, or Firefox.

3. Maximum number of users may be exceeded (4 users at a time).

@ vt x  +
< C @ F=2 | 192.168.2.121/app/dashboard * 9 O H =@

2

If it takes a long time to connect.

Possible causes :

1. Webview feature is disabled on this HMI.

2. This browser does not support Webview.

3. Maxinum connections for Webview has been reached.

Windows is a trademark or a registered trademark of Microsoft Corporation in the United States and/or other countries.

CODESYS is a trademark of 3S-Smart Software Solutions GmbH.

Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their respective companies.
This document is subject to change without prior notice.
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