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EasyBuilder Pro Quick Start Guide

Creating a simple project file in EasyBuilder Pro involves just a few steps:

Set PLC Device Parameters — Create Objects — Perform Offline or Online
Simulation — Configure HMI IP Address — Download Project File to HMI

Ensure that EasyBuilder Pro is installed on your computer before starting. This guide
uses a cMT2078X HMI and a PLC device with the MODBUS TCP/IP protocol as an
example.

1. Set PLC Device Parameters

Step 1. Open EasyBuilder Pro and create a new file.

Step 2. Select the model, check [Use template], and click [OK]. The template file
includes several preset windows, such as built-in keypads on windows 50 to
68 and 83 to 90, user password setup pages on windows 70 to 74,
EasyAccess 2.0 setup pages on windows 76 to 77, and the screensaver page
on window 80.

S . g
nt=r byweord t Flber winde
48
45
- 50 Keypad 1 - Integer |
1 51: Keypad 2 - Integer

51 Kayoad 2 - Intagar
53 Keymad 4 - Integer
54 Kaypad 5 - Int=gar
53 : Kevpad 8 - Integer
56 Keypad 7 - HEX
57 Kaypad 8 - Flosting
i~ 58: Keypad @ - Numenc
% = 35 Keypad 10 - Integeritranshucent)
- 60 ASCH Middla
1 54 : ASCH Small
] 62 : ASCH Upper M

naoonn

G M New Project 51 65 ASCH Lowar M
- 64 ASCH Upper§
open MRl [~ @ oMIT X Series - Standard B B3 AsckLowers
il B MTD{\S&)I(H 1 66 ASCH Mickde translucant)
wbdiizy b7 67 : ASCHl Upper Mitranslucant
[T Z07E -7 &8 - ASCH Lowar Mitranslucant)
3 cMT2108% F cMTZ10EXZ [ cMT2 10802 (V2) ek
T2 28 [ 70: Login & Logout
. : . =1 71 Add account
+ cMT2158K/ cMT2158X (W2} ] 72 Delete sceount
cMTZ188K 1 73 Set pralege
cMTI1ETN jmm} E;- Set pasrword
v B oM Iieries-m«acren’ MT207EX L 76+ Eaycrce: 2.0 Catting
cMT3072% / eMT307 262 [ 77 Esspticzmss 2.0 Proxy Satting
cMTI0T2XH / (MT20720H2 / eMT30T2HHT 78
cMT30TZXP iR ;g . .
5 cMTI0EE/ CMTI0SEE VE) bl
b cMT2102K / eMTI102K V2 O Paortrait [ 82 Vimchat Code
T2 108K [ 83 : System Standard ASCH
TIOEE Resohation : 100 x 450 -0 &4 Syatar Standlard ASCH Lowsr
— [ 85 : Systern Standard ASCII L
> CMTII524/ cMT3 52K V2 I 6t Syatern Erandrd HurmPar
» cMTIEZN/ cMTI B2 VT 1 &7 Systern Flat ASCHI
CMT-EHOX-220 [ 88 System Flat ASCI Laver
_EHOX- T 85: Systern Flat ASCH Upper
ChT-FHOX-520 1 90 System Flat MumPad
CT-SVRX-820 7 522 a1
~ A |ioT Gateway Series %2
chAT-GA 23
== En
B Use template (erplate_BO0sE0.contp) Lo
J . a5
a7
B
2
F 100
= o - 101
Uncompress Project| o4, On Project ol Cancel e
Incomp J Demo Proy CE e Windows Tres | Winlows Previcwy

’)

Step 3. On the [Device] tab, click [New Device/Server] to configure the PLC device to
be connected.

Step 4. This step uses a PLC device with the MODBUS TCP/IP protocol as an example.
Correctly set parameters such as IP address and port.

1 021-87700210
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Device Settings x |

MName : MODBUS TCP/IP

o Device

Location @ | gcal Settings...

* Select Local for a device connected to this HMI, or Remote for a device connected through another HMI.

Device type : MODEUS TCRIP | »

Pevice ID : 58, V.3.30, MODBUS_TCFIP.C33
IfF: Ethernet w Crpen Device Connection Croide. .

* Support offdine simulation on HMI {use LB-12358).

| IF: |192.168.1. 111, Port=502 | Settings... |

| [CJ Use UDP (User Datagram Protocol )

Device default station ne. : 1
[T Use broadcast command
] Default station no. use station no. variable

Hovw to desiznate the station no. in object’s address?..

Interval of block pack (words) : 32 - Address Range Limit...
Max. read-command size (words) : 120 e Data Conversion...
Max. write-command size (words) : 120 -
oK Cancel

Step 5. After clicking [OK], a new device will be added to the [Device list].

System Parameter Settings X
Cellular Data Network Time Sync,/DST e-Mail FTP
Device Model General System Remote Security Extended Memary
Device list: What's my IP?
Mame Location Device Type Interface
v Local HMI Local cMT2078X (800 x 480) -
MODBUS TCP/IP _ Local MODBUS TCP/IP Ethernet (IP=192.168.1.111, Port=502)

) 021-87700210
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2. Create Objects

The following describes how to create three repr:

D\- WE!NTEK

esentative objects and their

functions.
File B = s Home Project JeLIEasl Data/Histon
A % 7 () [l Picture @ Bit Lamp t2 Set Bit
@G [ oy 35 A [JShape = F WordLamp (& SetWord 3
F Table 1 [% Toggle Switch]
Draw Lamp

Step 1. Create a [Toggle Switch] Object:

v lloT/Energy  Wiew Tool Weincloud
Multi-State Switch =0 Slider 2
[E] Option List [ Ascll
"B Combo Button

Button/Switch Input

If there is a switch for a light on the PLC device and the goal is to control its switch on

the HMI, create this object. It is commonly used for operating bit addresses. Click
[Object] » [Toggle Switch], and under Read/Write, set the corresponding MODBUS
addresses for the light. Refer to the PLC Connection Guide for address mapping.

Mew Toggle Switch/Bit Lamp

General Security Shape Label

X

Comment:
(O Bit Larmp © Toggle Switch
[ Read/Write use different addresses
Read/Write
Device : | MODBUS TCP/IP «“«[ @ Ila
Address : | 0x 1
[ Invert signal
[T Wirite when buttan is released
Attribute
Switchstyle:  Toggle w

Set the switch style to Toggle, meaning that if the initial state is 0 (OFF), clicking it

once will set it to 1 (ON). Besides the default images included in the system, it is also

possible to add or modify images for each state i

I New Toggle Switch/Bit Lamp x I New Toggle

| General s
|

| General Security Shape Label
|

State: 0

Picture : [lamp - Ribban
[5YSTEM

|pBx69

o o

1

Picture Picture

8 Use picture Picture Library...

B Use picture

n the Shape tab.

Switch/Bit Lamp

ecurity Shape  Label

State: |1

Picture : [lamp - Ribban
[5YSTEM

|pBx69

1

Picture Library..
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Step 2. Create a [Numeric] Object:

Various data such as temperature and humidity from sensors often exist in PLC

devices. This object can display the data or set parameters. Click [Object] » [Numeric]

and configure, including the read/write addresses.

JHED lEEfﬂ b

Mumeric's Properties x

General Data Entry Format Trigger Action Setting Security Shape Font  Profile

Comment :

B Allow input i)

[CJ Read/Write use different addresses

Read/Write
Device: MODBUS TCP/AP ol @ I[a
Address: 4x 1

Step 3. Create a [Function Key] Object:

To create an intuitive project interface, it is often necessary to display popup

windows or switch between full-screen windows. Use [Function Key] to create these

functional buttons. Click [Object] » [Function Key] and configure the functions as

needed.

Function Key's Properties X

General Security Shape Label Profile

Comment :
Attribute
Type: Window -
[ Activate after button is released
Window
Function: | Display popup window -
Window no.: 70.Login & Lagout ~
Title bar/Position...
Animation : Settings... [Mone, None]
B Close this popup window when parent window is closed
B show close button
Motification
] Enable

www.nicsanat.com
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Step 4. Properly place the objects in the editing window to complete a simple
project file.

EasyBuilder Pro V6.09.02.469 : EBProject1 - [10 - WINDOW_010 |

Fle H & « » ; QELNUEE Project  Object Data/History lloT/Energy  View Tool Weincloud

- E N - -

D (VD pAEAYmAE-E :
oo BB/ »&% OGO~

System ; =l D t AA T A-U E-oe- .4
Parameters i AMOH® Aesd & )s N -
Clipboard Editing Object Arrange Font

Cut ]

Paste 20y

Windows Tree X 4 10 - WINDOW_010 x

[ TPy < PSRN < YT IPININY. ;i IR IR YUY MOVPYIRIUPRIRURY: . MRPUTNIRTUIRITY: i MOTHITITIN YLy RYIR A IIOR

Enter keyword to filter windows

= 10: WINDOW 010
I TS0 (0x-1) (Back) |
- NE_O (4x-1)

o

et PR P B M P

rrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrTT
n
N}

EasyBuilder Pro offers a variety of objects with different functions. When designing
project files, select objects according to needs. For details on available objects, refer
to the EasyBuilder Pro User Manual.
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3. Simulate the Project File

EasyBuilder Pro offers two types of simulation:

Offline Simulation: Operates without a connection to the PLC device and is used to
verify whether the project file functions as designed.

Online Simulation: Communicates with the PLC device to reflect actual HMI-PLC

behaviors.

File H & « s Home MYGZudl Object Data/History lloT/Energy View  Tool

S ® ¥[p B @ B m

System Language Compile Online Offline Download Build Download Reboot
Message & Font Simulation  Simulation| (PC->HMI) Files HMI
Setting Build

Offline Simulation

Step 1. Save the project file.

Step 2. Click [Project] » [Compile].

Step 3. Click [Compile], and after completion, click [Close].

Compile X

|
: Project name : C:\Users\Desktop\cMT2078X_Quick_Start.cmtp

CXOB file name : C:\Users \Desktop\oMT2078X_Quick_Start.cxab

B Decompilation is prohibited [C) Disable HMI upload function

Select the languages used on the HMI
Startup language after redownloading the project : | Language 1

B Language 1

Treat the use of unsupported tags as | Error v
Cutput Error List
Total size : 3668719 bytes (3.50 MB)
Free space : 63440145 bytes (60.50 ME)

Project Checksum : Secd5a23a05a2¢1159ee68f698b55che
0 error(s), 0 warning(s)

| succeeded

Double-click a message to modify the attributes of the object in question

Quick Compile Font Management.,., {8 Buid font flles

Step 4. Click [Offline Simulation] to verify the relative position and basic operation

of objects.
;
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Step 5. The [Toggle Switch] and [Numeric] objects display offline without
attempting communication with the PLC device. Check if the [Function Key]

object operates the popup window correctly.

%, cMT Viewer ( Simulation ) i m| x

Login by Index

index | admin o IEN
Password m

Online Simulation
Step 1. Ensure computer communication with the PLC device, and after clicking
[Online Simulation], verify communication with the device.

Step 2. The software will reflect the actual values in the PLC device.

2, cMT Viewer ( Simulation ) B = ”

N
r |

7 021-87700210
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4. Configure HMI IP Address

Automatic I[P Configuration

Step 1. Power on the HMI and connect to LAN. Ensure there is a DHCP server on the
LAN.

Step 2. Tap theicon © inthe top left corner of the HMI.

Step 3. Tap [Network] from the left menu, then [Configure] on the right, and try to
modify settings.

Setting o EXITE Network
. Ethernet LAN2
. System Properties
Model /HMI.Name /O Configure Automatic >
CODESYS 2
Activate COBESYS /b IP Address 192.168.2.191
Subnet Mask 255.255.252.0
Project
Clear History / Restart ... Gateway 192.168.1.254
Network 168.95.1.1
@ o N DNS 68.95
ernet / Configure / I...
Enable CODESYS Login [ @)

e Security
Admin / Update Projec...

e EasyAccess 2.0

Version / Activation Sta...

Step 4. To modify settings, log into the system settings. Enter the default password
111111 and press enter.

Step 5. Select [Automatic] and click [Save]. Once successful, the HMI will obtain a
LAN IP address.

Setting @ eI E < Network Configure Save
Admin, o .
Automatic v
System Properties
@) Model / HMI Name / O... Manual
0 CODESYS
Activate CODESYS / Re...
Project
Clear History / Restart ...
Network
Ethernet / Configure /I... k
e Security
Admin / Update Projec...
3 021-87700210
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Manual IP Configuration

EI WEI!NTEK

Step 1. If the LAN has no DHCP server, open the command prompt by typing ‘cmd’

in the computer's search interface. Then, use the command ‘ipconfig’ to

check the computer’s network settings.

B Command Prompt

Step 2. Choose [Manual] in Network settings, input the same subnet as the

computer, and click [Save]. Once successful, the HMI will obtain a LAN IP

address.

Setting @B iep

Admin, &

System Properties
* Model / HMI Name / O...

CODESYS
Activate CODESYS / Re...
Project

Clear History / Restart ...

x Network

" Ethernet/ Configure /1...

0 Security
Admin / Update Projec...

Subnet Mask

< Network Configure Save
Automatic
Manual v
IP Address 192.168.1.191

255.255.252.0

Gateway 192.168.1.254
DNS 168.95.1.1
k
9 021-87700210
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5. Download Project File to HMI

Step 1. Click [Project] » [Download (PC->HMI)].
Step 2. Select the target HMI for download and click [Download].

| Download (PC->HMI) K
|

© Ethernet Password,Port no. of download/upload : | Settings...

4 1B/ HMIName b

HMI |cMT2EI?8X—FAE—4-892 ~ | [192.168.2.52 (Default-test
192.168.2.8 (cMT2078X-FAE-4892)
Search
Search All

What's oy IP7?

Project Checksum @ SecdSa23a05a2c1159ee68f698b55che

B Runtime * Necessary if update runtime or execute download first time.

[CJ Use system settings file

[ synchronize HMI clock with PC

B Reset recipe (RW, RW_A) @ Reset event leg B Reset data sampling

B Reset recipe database B Reset operation log B Reset string table
@ Reset PRW on HMI and all chT Viewers

() Automatically using current settings to download after compiling

Step 3. After downloading, verify the HMI interface. If the following screen appears,

it indicates communication failure between HMI and PLC. Check connections

and communication parameter settings.

mla Device No Response

www.nicsanat.com
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Step 4. If the following screen appears, it indicates successful communication
between HMI and PLC.

/ \
/ \

u

10

Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their
respective companies.

This document is subject to change without prior notice.

Copyright® 2024 WEINTEK IOT LTD. All rights reserved.
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